首页  »   JavaScript

nodejs版本更新有关问题:express不是内部或外部命令

网友分享于:2015-06-08  浏览:0次
nodejs版本更新问题:express不是内部或外部命令

 安装之后就需要安装express,使用熟悉的npm install -g express命令安装,但是,安装成功之后居然提示express不是内部或外部命令.
nodejs小问题:[1]express不是内部或外部命令
nodejs小问题:[1]express不是内部或外部命令
 为什么会这样子呢?当我们找到安装后的express目录发现比之前熟悉的express少了很多东西.
nodejs小问题:[1]express不是内部或外部命令
nodejs小问题:[1]express不是内部或外部命令
 怎么办呢? 猜测是express版本更新了,但是我们不知道新版本该怎么玩了.所以我就只好先删除当前安装的express,重新安装以前的版本试试.测试ok.
    此处使用的命令有
    卸载: npm uninstall -g express
    安装指定版本: npm install -g [email protected]
    查看版本: express -V
    注意express -V中的V要大写,不然很多版本中会不识别
nodejs小问题:[1]express不是内部或外部命令
nodejs小问题:[1]express不是内部或外部命令
nodejs小问题:[1]express不是内部或外部命令
      当然,你只是想要解决express命令不能识别的问题.此时你已经达到目的了.但是为什么新版本我们用不了呢?
     原来,最新express4.0版本中将命令工具分家出来了(项目地址:https://github.com/expressjs/generator),所以我们还需要安装一个命令工具,命令如下:
npm install -g express-generator
 
于是我又删除之前的express3.5.0再次安装express4.0及其命令工具
nodejs小问题:[1]express不是内部或外部命令
nodejs小问题:[1]express不是内部或外部命令
 既然安装好了我们就要测试一下新安装的express到底可不可以使用
    于是我使用express创建一个工程:
   express helloworld
   新版本中命令发生了一些改变, 创建好project之后还需要用npm进行添加依赖和启动:
   cd helloworld
   npm install
   npm start

   然后新创建的helloworld就已经运行在3000端口上
nodejs小问题:[1]express不是内部或外部命令
 访问http://localhost:3000/就看到熟悉的页面了
nodejs小问题:[1]express不是内部或外部命令
 以及创建出来的目录效果
nodejs小问题:[1]express不是内部或外部命令
 此时真的就大功告成了,express新版本还真有些变化的.呵呵.其他的新特点也等待我们大家去发现.

注意事项
安装指定版本时需要使用npm install -g [email protected]这样的命令
用express创建后的project一定要使用npm install在project目录下添加依赖才可以运行
运行应用不再是node app.js而是npm start

相关解决方案

最新解决方案