首页  »   J2EE

J2EE项目发布有关问题1-Tomcat版本有关问题

网友分享于:2013-07-25  浏览:0次
J2EE项目发布问题1--Tomcat版本问题

项目是在Tomcat7和JDK7环境下开发的,运行正常。在项目发布到Tomcat6,JDK7环境下时,发生莫名异常org.apache.jasper.JasperException: /WEB-INF/jsp/xxx_list.jsp(85,6) The function indexOf must be used with a prefix when a default namespace is not specified
org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:40)
...........

后把服务器环境中的Tomcat6该为Tomcat7无异常发生。

问题解决。原因可能是项目中lib文件夹中的jar包问题,jar包在Tomcat7运行正常,而在6中则有问题,无法兼容jar包,这里估计是我的jstl.jar包不被6兼容。

总结:开发环境最好是和项目发布的服务器环境一样,避免发布时出现问题。

相关解决方案

最新解决方案