首页  »   J2EE

The server does not support version 3.2 of the J2EE EJB module specification

网友分享于:2017-01-12  浏览:1次
The server does not support version 3.2 of the J2EE EJB module specification.

今天用Eclipse部署一个Web项目Test,报如下错误:T The server does not support version 3.2 of the J2EE EJB module specification.

原来创建Test时用的是ejb3.2,而现在用的是jboss4.2只支持到ejb3.0。



解决如下: 

在项目根目录下有一个.settings的文件夹,该文件夹下有一个org.eclipse.wst.common.project.facet.core.xml文件,内容如下: 

<?xml version="1.0" encoding="UTF-8"?>

<faceted-project>

  <runtime name="WildFly 8.x Runtime"/>

  <fixed facet="jst.ejb"/>

  <fixed facet="java"/>

  <installed facet="java" version="1.7"/>

  <installed facet="jst.ejb" version="3.2"/>

</faceted-project>

 

 把<installed facet="jst.ejb" version="3.2"/>改为  <installed facet="jst.ejb" version="3.0"/>

然后refresh重新加载配置,celan重新编译。就可以部署了

 

相关解决方案

最新解决方案