首页  »   人工智能

nodemailer 使用时碰到的有关问题

网友分享于:2013-03-06  浏览:0次
nodemailer 使用时碰到的问题
nodemailer包加入后出现如下问题:

fangdeMacBook-Air:ah fxc$ node ./server.js
/Users/fxc/work-on-node/ah/node_modules/nodemailer/lib/mailer/index.js:31
            compile: [(...args) => this._convertDataImages(...args)],
                       ^^^

SyntaxError: Unexpected token ...
    at exports.runInThisContext (vm.js:53:16)
    at Module._compile (module.js:373:25)
    at Object.Module._extensions..js (module.js:416:10)
    at Module.load (module.js:343:32)
    at Function.Module._load (module.js:300:12)
    at Module.require (module.js:353:17)
    at require (internal/module.js:12:17)
    at Object.<anonymous> (/Users/fxc/work-on-node/ah/node_modules/nodemailer/lib/nodemailer.js:3:16)
    at Module._compile (module.js:409:26)
    at Object.Module._extensions..js (module.js:416:10)

   
    解决方案:

    从github上搜到 nodemailer,下载到本地测试,仍然报同样错误,查看package.json文件,发现有一条
    "engines": {
        "node": ">=6.0.0"
    }
    在命令行 $node -v 发现我的本地nodejs版本是4.xx,太老了。感觉是这个问题,查询如何升级。
    分两步:
    #sudo npm install -g n
    #sudo n stable

    再次查看版本
    #node -v
    已经是9.xx

    再次运行nodemailer,发现问题解决!!! cool

相关解决方案

最新解决方案